WordPress 4.9.10和5.1.1版本发布,修正一些安全问题

 2019-03-13 12:01:10  348 人阅读  17 条评论

刚才收到邮件才知道站点被自动升级到 4.9.10 版本,查看了介绍发现 WordPress 4.9.10 版本是在 2019 年 3 月 13 日向公众发布,主要是更改包括一对安全修复程序,用于处理如何过滤注释然后存储在数据库中,欲了解更多,参见发行注记。修改的系统文件如下:

  • src / wp-includes / formatting.php
  • src / wp-comments-post.php
  • src / wp-admin / includes / ajax-actions.php

不管怎么样,对于还坚守在 4.9 版本的站长们,建议大家关注一下是否已经成功自动升级到 4.9.10,如果无法自动升级可以登录站点后台 >> 仪表盘 >> 更新进行操作,或直接点此下载 4.9.10上传覆盖安装(PS:不懂手动升级的可参考『如何手动升级 WordPress 到最新版本/还原到旧版本』)。

今天 WordPress 也同时发布了 WordPress 5.1.1 版本,这个安全和维护版本引入了 10 个修复和增强功能,包括旨在帮助主机为用户准备 5.2 中最小 PHP 版本的更改,同时也修复了以下问题:

  • 一对安全修复程序,用于处理如何过滤注释然后存储在数据库中。
  • 使用恶意制作的评论,WordPress 帖子很容易受到跨站脚本攻击。
  • WordPress 版本 5.1 及更早版本受这些错误的影响,这些错误在 5.1.1 版中得到修复。
  • WordPress 5.0 及更早版本的更新版本也可用于尚未更新到 5.1 的任何用户。
  • 主机现在可以为其用户提供更新 PHP 的按钮。
  • 现在可以过滤“更新 PHP”通知使用的推荐 PHP 版本。
  • 几个小错误修复。
  • 有关更改的完整列表,请参阅完整更改列表
  • 欲了解更多,参见发行注记WordPress5.1.1 版本介绍

WordPress 5.1.1 版本修改的系统文件如下:

  • /wp-admin/js/widgets/custom-html-widgets.js
  • /wp-admin/about.php
  • /wp-admin/css/nav-menus.css
  • /wp-admin/images/loading.gif
  • / wp-admin /includes/ajax-actions.php
  • /wp-admin/includes/class-wp-plugin-install-list-table.php
  • /wp-admin/includes/dashboard.php
  • /wp-admin/includes/misc.php
  • / wp -includes / comment.php
  • /wp-includes/formatting.php
  • /wp-includes/functions.php
  • /wp-includes/js/comment-reply.js
  • /wp-includes/ms-site.php
  • / wp-includes / version .PHP

建议大家关注一下是否已经成功自动升级到 5.1.1,如果无法自动升级可以登录站点后台 >> 仪表盘 >> 更新进行操作,或直接点此下载 5.1.1上传覆盖安装(PS:不懂手动升级的可参考『如何手动升级 WordPress 到最新版本/还原到旧版本』)。

您可能感兴趣的文章

文章标签:
本文地址:https://boke112.com/6546.html
版权声明:本文为原创文章,版权归  所有,欢迎分享本文,转载请保留出处!
©boke112导航,本站推荐使用:阿里云 ECS服务器等云产品服务,国外免备案主机建议使用:老薛主机

阿里云专题 腾讯云专题虚拟主机专题WPS专题

 发表评论

大笑表情偷笑表情鼓掌表情思考表情疑问表情抠鼻表情抓狂表情晕表情黑线表情流汗表情流泪表情囧表情衰表情围观表情OK表情牛表情

  1. 运维学习笔记博客
    运维学习笔记博客 @回复

    最近我的ECS一直无法更新!比较郁闷!

  2. 镜缘轩
    镜缘轩 @回复

    今天看到了 已更新

  3. 神器
    神器 @回复

    新的永远是好的

  4. 子午物联网
    子午物联网 @回复

    我都很久没有升级了

  5. 弥雅尔尔
    弥雅尔尔 @回复

    其实5.0往上,弥雅还是建议升级的,新编辑器的问题是可以很快解决的!

    • 懿古今
      懿古今2019-03-14 11:28  回复

      @弥雅尔尔[呲牙] 其实我也搞不懂4.9和5.0除了编辑器之外还有哪些改进和优化,不过还是选择升级到5.1.1

  6. 清风小墨
    清风小墨 @回复

    4.9为什么会有那么多人坚持呢

    • 懿古今
      懿古今2019-03-13 22:10  回复

      @清风小墨5.0之后就是新增了新编辑器,理论上4.9就足够使用。升级到5.0之后还要禁用块编辑器,这个估计是坚守4.9的重要原因吧

  7. 去看你博客
    去看你博客 @回复

    一直都没升5.0 [抠鼻]

  8. 励志语录网
    励志语录网 @回复

    已经自动更新,翻译还是不完整