WordPress 5.2.3维护版本修复29个错误,建议及时升级

互联网  2019-09-05 10:28:19  92 人阅读  17 条评论

2019 年 9 月 4 日,WordPress 5.2.3 向公众发布,9 月 5 日正式推送 5.2.3 维护版本,这个安全和维护版本修复了 29 个错误,包括一些安全修复程序,具体请参阅下面的列表:

  • #38415:新的自定义链接菜单项具有错误的后备标签
  • #45739:块编辑器:$ editor_styles 错误。
  • #45935:do_block_editor_incompatible_meta_box 函数中的 URL 没有 classic-editor__forget 参数
  • #46757:媒体废纸篓:废纸篓中的批量介质选项不应提供两个主要按钮
  • #46758:媒体垃圾:主要按钮应位于左侧
  • #46899:确保 Settings API 生成的表没有语义
  • #47079:excerpt_allowed_blocks 过滤器的版本不正确
  • #47113:媒体视图:关闭通知按钮是不可见的
  • #47145:“特征图像”对话框不遵循对话框模式
  • #47190:二十七:本机音频和视频嵌入没有焦点状态。
  • #47340:Twenty Nineteen:修改最新帖子阻止样式以支持帖子内容选项。
  • #47386:修复旧版自定义背景和自定义页眉页面中的标题层次结构
  • #47390:改进某些“表格”表单中表单元素的可访问性
  • #47414:二十七:按钮块预览在按钮内有额外的间距
  • #47458:修复媒体附件浏览器中的标签顺序
  • #47489:表情符号在预先格式化的块中被替换
  • #47502:媒体模式底部工具栏切断 Internet Explorer 11 中的内容
  • #47538:Minor Verbiage Update - 为'开发者'切换'开发时间'
  • #47543:二十七:按钮在悬停和聚焦时不会改变颜色
  • #47561:插件:查看详细信息弹出布局问题
  • #47603:我的帐户在管理栏上切换在高缩放级别时不可见
  • #47604:未定义的变量:已锁定在 wp-admin / edit-form-b​​locks.php 中
  • #47687:在编辑器中为图库图像使用 alt 标签
  • #47688:在 RTL 安装中以 RTL 显示而不是 LTR 的颜色选择器中的颜色十六进制代码(取 2)
  • #47693:定制器颜色选择器应该在单击颜色选择器区域时关闭。
  • #47723:在 nav-menus.php 中添加自定义链接不会修剪空格
  • #47758:安装屏幕上的字体大小太小
  • #47835:对于插件,PHP 要求始终设置为 null
  • #47888:通过 Customize 在菜单中添加自定义链接不会修剪空白。

安全修复

  • 向 RIPS 科技公司的 Simon Scannell 寻找和披露两个问题的道具。第一个是贡献者在帖子预览中发现的跨站点脚本(XSS)漏洞。第二个是存储的评论中的跨站点脚本漏洞。
  • 向 Tim Coen 道歉,披露了 URL 的验证和清理可能导致开放重定向的问题。
  • Anshul Jain 向媒体上传过程中披露反映的跨站点脚本的道具。
  • Fortinet FortiGuard Labs 的 Zhouyuan Yang 的道具,他们披露了短代码预览中跨站点脚本(XSS)的漏洞。
  • 向核心安全团队的 Ian Dunn 发布道具,用于查找和披露可在仪表板中找到反映的跨站点脚本的案例。
  • 来自 NCC Group 的 Soroush Dalili(@irsdl)的道具,披露了可能导致跨站点脚本(XSS)攻击的 URL 清理问题。
  • 除了上述更改之外,我们还在旧版 WordPress 上更新 jQuery。此更改已在 5.2.1 中添加,现在正在使用旧版本。

有关更改的完整列表,请参阅  Trac 上的门票列表

WordPress 5.2.3 维护版本已经推送更新,各位 WordPress 站长可以在网站后台直接更新即可(大部分站点是自动升级,失败的话只能手动升级了,具体可参考『如何手动升级 WordPress 到最新版本/还原到旧版本』)。或者直接在此点击下载 WordPress 5.2.3 版本或其他 WordPress 版本

英文原文:https://wordpress.org/support/wordpress-version/version-5-2-3/

您可能感兴趣的文章

文章标签:
温馨提示:文章内容仅代表作者个人观点,不代表boke112导航赞同其观点和对其真实性负责!
版权声明:本文内容来源于互联网资源,由 boke112导航 整理汇总,如有侵权请与老古(QQ:2226524923)联系,老古将及时更正、删除,谢谢!
©boke112联盟,本站推荐使用:阿里云 ECS服务器等云产品服务,国外免备案主机建议使用:老薛主机
整理砖家

 发表评论

大笑表情偷笑表情鼓掌表情思考表情疑问表情抠鼻表情抓狂表情晕表情黑线表情流汗表情流泪表情囧表情衰表情围观表情OK表情牛表情

  1. 南瓜IT
    南瓜IT @回复

    自动更新了

  2. 凯少技术网
    凯少技术网 @回复

    WP更新好快,快到让人窒息,这究竟是好事还是坏事呢?

  3. 开红大大的博客
    开红大大的博客 @回复

    已经更新咯

  4. 轩沫博客
    轩沫博客 @回复

    赶紧更新了。

  5. 唯心寒辞
    唯心寒辞 @回复

    WP又更新了,还好我现在不用人工升级了

  6. MAY的SEO博客
    MAY的SEO博客 @回复

    看到大家的评论,我想我也要去更新WP了~

  7. 经典语录网
    经典语录网 @回复

    wordpress更新得好快哦

  8. 明月登楼
    明月登楼 @回复

    竟然发现wp-cli可以更新了,但是需要升级到2.2.3版才可以稳定!

  9. 明月云服务
    明月云服务 @回复

    已经自动更新了!

  10. wordpress建站吧
    wordpress建站吧 @回复

    刚收到另一个站的自动更新邮件提醒。。。

    • 懿古今
      懿古今2019-09-05 11:25  回复

      @wordpress建站吧我在老薛主机上的WordPress站点都自动更新升级了,阿里云服务器上的WordPress站点每次都失败,总是要人工升级。