宝塔Linux面板如何一键切换网站的PHP版本?

 boke112联盟   2020-10-16 20:37:41 更新  宝塔面板

现在 WordPress 站点一般都要求最低的 PHP 版本是 5.6,建议 7.0 以上(详见『WordPress 官方确认不再支持 PHP5.2~PHP5.5』),那么安装有宝塔 Linux 面板的站长如何实现一键切换网站的 PHP 版本呢?

1、登录宝塔 Web 面板 >> 软件商店 >> 运行环境 >> 安装想要切换的 PHP 版本,如原先安装有 PHP7.1,想要切换到 PHP7.2,那么就直接点击 PHP7.2 右侧对应的“安装”按钮,稍等片刻即可成功安装。具体如下图所示:

宝塔Linux面板如何一键切换网站的PHP版本? - 第1张 - boke112联盟(boke112.com)

2、点击左侧菜单“网站”>> 点击相应网站右侧的“设置”按钮 >> 点击左侧的“PHP 版本”>> 在 PHP 版本下拉选项中选择 PHP-72 >> 点击【切换】按钮,稍等片刻即可成功切换 PHP 版本。具体如下图所示:

宝塔Linux面板如何一键切换网站的PHP版本? - 第2张 - boke112联盟(boke112.com)

宝塔 Linux 面板允许同时安装和运行多个 PHP 版本,这样可以让不同的网站使用不同的 PHP 版本。不过 boke112 问答还是建议大家尽量只运行一个 PHP 版本会更好,毕竟多个 PHP 版本同时运行会占用资源。建议切换到最新版本之后,不用的 PHP 版本可以点击“设置”>> 点击【停止】按钮让其停止运行,或者直接点击“卸载”按钮卸载它,有需要时再安装也行。

boke112联盟建议:如果你想更简单地使用服务器,推荐使用宝塔面板,支持Linux与Windows系统,欢迎点此前往宝塔官网注册账号并领取¥3188元礼包(专业版永久授权低至1188元哦)!更多关于宝塔面板的文章请移步『宝塔面板栏目

您可能感兴趣的文章

文章标签: ,   ,  更多热门标签>>
版权声明:本文为原创文章,版权归 boke112联盟 所有,欢迎分享本文,转载请保留出处!发布此文是出于传递更多信息之目的,若有来源标注错误或侵犯了您的合法权益,请与老古(QQ:2226524923)联系,老古将及时更正、删除,谢谢。
  1. 雅兮网
    雅兮网

    老古也开始开始折腾宝塔了?

    • 懿古今
      懿古今2019-05-06 11:37

      @雅兮网[呲牙] 刚好有一台阿里云服务器还有一个月空闲,加上获赠半年的宝塔面板,所以就随意折腾一下,顺便水水文章

  2. 里维斯社
    里维斯社

    宝塔面板使用非常简单方便,但是比较占用服务器资源啊

    • 懿古今
      懿古今2019-05-06 11:39

      @里维斯社应该会比不用的占资源,但是用了管理服务器比较方便,如何取舍就看个人了

  3. 情话大全
    情话大全

    上周刚开始接触服务器

    • 懿古今
      懿古今2019-05-06 11:40

      @情话大全有精力的话折腾服务器还是不错的,比虚拟主机可折腾的东西多很多